Problem with weather


New member
Hello friends.

Recently I am testing version 5.7 since I was testing 5.6 and I liked it. After knowing that they have added new functions I am testing it. There is a function that has stopped working:
The weather.
My case is that I am close to Barcelona, ??Spain and the command that I have used is that which corresponds to the town of L'HOSPITALET DE LLOBREGAT.
The way to introduce it was like this:
weather LHOSPITALET%20DE%20LLOBREGAT, ES, since otherwise it did not connect.
If you choose a city whose name does not have spaces, do not put this "%20", for example Barcelona,ES, but in my case it does have spaces and you have to put it.
The fact is that with version 5.7 it has stopped working.
If it is set as it was in 5.6  (exported from 5.6 and imported in 5.7) it gives as error: "Weather update error: HTTP/1.1 404 Not Found"
If the "%20" is removed and the corresponding spaces left, it gives the same error.

My question is:
Have you checked the cities with spaces in your name?
Why it worked before and now not.
When the city does not have spaces in its name, it does work.

I am looking forward to your response.


Well-known member
Staff member
It could be a bug in the software, we'll check it and it'll be fixed in the next update (RadioBOSS 5.7.2, within a week or two).