[Windows Update] How to prevent automatic rebooting

djsoft

Well-known member
Staff member
By default, Windows installs its updates automatically and if a computer restart is required to finish the installation, it's typically performed (automatically) at around 3AM. Restarting causes all programs, including RadioBOSS, to be closed, which may not be the desired behavior.

In order to prevent this, automatic reboot should be disabled.

1. Press Windows Key+R to open the "Run..." window. Enter gpedit.msc and click OK.

2. Navigate to
Computer Configuration\Administrative Templates\Windows Components\Windows Update

3. Set the following options:
- Configure Automatic Updates: Enabled, 4, Every Sunday
- No auto-restart with logged on users for scheduled automatic update installations - Enabled

Note: both options have to be set. If you only enable the "No auto-restart...", it is NOT enough and computer will still restart!

This solution is not available for Windows 10 Home, it's only for Pro and Enterprise editions. Windows 10 Home does not offer the gpedit.msc tool. Alternate solution is to enable the "Start with Windows" option in RadioBOSS: http://manual.djsoft.net/radioboss/en/general.htm

Security notice. As computer is not rebooted automatically anymore, some updates (including security updates) that required a reboot will not be installed. You should finish update installation manually from time to time: open the Start menu, click the Power icon and select the "Install updates and reboot" option. Do so every e.g. every 4-8 weeks.
 
Last edited:
Top