Music Library has disappeared with RadioBOSS upgrade 6.0.6.2

Hello Dmitry,

Yesterday I renewed our licence keys for RadioBOSS, RadioLogger and RadioCaster.

Both the RadioLogger and RadioCaster updates have been done and are working correctly.

The RadioBOSS update was 99% successful but has left us with three problems:

1. The regular tab player screen is all over the place - meaning the columns are nothing like they were before. I have altered the columns as best I can but I cannot remember exactly what they layout was before. I would have thought those settings would have been preserved from the previous version. Is this the case ?

2. The regular tab player has weird looking icons for Prelisten, Play and Delete. I cannot find where to adjust them. Any ideas ?

3. On the regular tab player the Search tab and search box on the right is empty and does not show any music search results. I cannot see where the music library search database is located so I cannot fix it. We are unable to select music and put it to air.

Here is an update:

4. After 4 hours I can see a problem.

On older versions (5.9.4.0) > Settings > Options > General window at the bottom has:

Music Library folder: \Database\
Voice Track folder: \VoiceTracks\

On this current version (6.0.6.2) > Settings > Options > General window at the bottom only has:

Voice Track folder \VoiceTracks\

No box for the music database. Could that be the trouble ?

Can you give me any ideas ?

Thanks, Jamie C.

Radio Dungog
 

djsoft

Well-known member
Staff member
1. The regular tab player screen is all over the place - meaning the columns are nothing like they were before. I have altered the columns as best I can but I cannot remember exactly what they layout was before. I would have thought those settings would have been preserved from the previous version. Is this the case ?
The playlist was reworked, therefore column configuration can't be loaded from the previous versions because column sets are different between the versions, I'm sorry.

2. The regular tab player has weird looking icons for Prelisten, Play and Delete. I cannot find where to adjust them. Any ideas ?
All icons are new in this version. It offers two icon sets, you can change them in Settings / View / Style.

I cannot see where the music library search database is located so I cannot fix it. We are unable to select music and put it to air.
Starting with version 6, RadioBOSS uses SQLite to store music database, instead of XML files as it did before. It solves various problems, mostly performance-related. You can import the old XML files into the new music library. If you use the makelibrary command in the scheduler, please change music library paths there to use only library names.

RadioBOSS 6 is a major update, with lots of major changes. We had to make them in order to move forward.
 
Hello Dmitry,

Okay, I am regenerating the music library search database from our music storage folders. That seems to be generating the database okay and I can now search for songs. Can you please tell me where the database is stored ?
 

djsoft

Well-known member
Staff member
I don't understand what you have said here.
This is for the case if you have scheduled automatic library update from the scheduler, it will generate an event with the makelibrary command, and this event will need to be updated.

Can you please tell me where the database is stored ?
Please open Settings, General. If you have SQLite selected for "Additional information location", click Settings and it will show you the path to the database file. The libraries are stored there.
 
I have > Settings > General > Additional track information storage location > File tag (APEv2) is selected

Should I have a different option selected like Database SQLite ?
 

djsoft

Well-known member
Staff member
Should I have a different option selected like Database SQLite ?
Generally, no. The default for new installations now is SQLite, if you switch now, you will lose all additional info (playcount, custom tags etc). It is possible to convert from APEv2 to SQLite, but if APEv2 works for you, I wouldn't do anything.

The Music Libraries in this case are stored in SQLite anyway, the file is located one level up from the settings folder - click Settings->Open Settings Folder menu item, then go one folder up, the libraries are in the Tracks.db file.
 
Thanks for all the answers Dmitry.

On the > Tools > Music Library page > Help > Contents it mentions the following:

4. To save the changes, click the Save button.

I cannot see any Save button on the Music Library page.

In past versions there was a Save button but not in this version

Is that correct ?
 

djsoft

Well-known member
Staff member
The save button was removed starting with version 6, the library is saved automatically.
 
Okay on automatic save. Can you please tell me what initiates the automatic save ? Last week I initiated a Music Library re-generate and it ran all night and was still running at 6 am in the morning and then by 8 am the thing had locked up. I then closed the Music Library but I was unsure how much of it would have been saved. The Music Library window indicated 266,074 tracks so I assume it must have been doing regular saves during the process. Is that correct ?
 

djsoft

Well-known member
Staff member
Can you please tell me what initiates the automatic save ?
Any action you perform. Adding, removing a track, editing anything.

Last week I initiated a Music Library re-generate and it ran all night and was still running at 6 am in the morning and then by 8 am the thing had locked up.
That's odd. How many track did it have to index? Also, how did you run it, using a scheduled event, or you added a folder in the Music Library directly?

The Music Library window indicated 266,074 tracks so I assume it must have been doing regular saves during the process. Is that correct ?
Yes, the progress is "saved" (in quotes because there's no actual save performed because it works with a database) while the operation is performed. 266k tracks sound like a lot. Are you sure that you have included the correct directory for it to index?
 
Last edited:
We use a multi-HDD NAS to store our music folders and files and the primary storage area is the L drive (L = Library) and we have another W drive (W = Working) where presenters put their music files. So to create the music library search engine database I selected the L drive at first and that was complete in a few hours, then I selected the W drive. I don't know how many music files we have - I only know that the music library window shows that 266k quantity after it locked up. We intend moving the presenter music folders and files to the L drive in the future so that oir storage procedure is consistent and sensible.

I have been careful to use different terminology with our presenters so they understand the true meaning of the music library items:
a) Music Library = hard drive storage that holds the music folders and files
b) Music Search Engine = RadioBOSS tool that creates a database search engine and lets them find songs and artists
 
Last edited:

djsoft

Well-known member
Staff member
When adding the whole drive, it will add all files that have supported extension (mp3, wav etc), I'd recommend only adding the folders with music. Or you actually have 266k music files?
 
On the Music Library window it shows: Tracks 266074 Duration 728d 3:57:06 There would be many duplicates stored on the W drive as some presenters have got into the habit of making copies of songs and putting them in folders for their shows instead of putting them in a playlist.
 

djsoft

Well-known member
Staff member
It's OK to have that many tracks in the library, however it may slow down some operations.
 
Has the "Add comment" feature changed on version 6 ? I have been getting red error messages in the bottom left log saying:

Unable to play! Error code 2 (unable to open the file/invalid server address.)

I have removed the comment entry from each playlist and the error no longer appears.
 
The event scheduler pulls in a playlist of sponsor messages (adverts) which contains 4 line items:
i) text comment
ii) audio file
iii) audio file
iv) audio file

When the contents of the playlist is played the text message initiates the error message on the text comment. The audio files play as normal:

Unable to play! Error code 2 (unable to open the file/invalid server address.)

I have removed the comment entry from each playlist and the error no longer appears.
 
Top