Top of the hour glitch

I had strange behaviour today - ran a program A with length 1.59.59.7 that was supposed to finish at 4PM when a new scheduled program B was meant to start exactly (without waiting for anything to finish). Program B had a sweeper programmed in (with 1 sec accuracy) for those times that program A did not finish so close. In the latter case it always works perfectly.

This is what occurred: Program A completed on time, but instead of Program B playing at 4PM, a sweeper track dropped in momentarily (for about 2 seconds), followed by Program B. This should not have happened - why did program B fail to take priority over a sweeper track (or was it a left over track in the playlist perhaps)?

Is this caused by my selection of sweeper accuracy being too tight or do I need to clear the playlist? What is the effect of reducing the sweeper accuracy to, say, 5 sec? Does RB know if there is a 5 sec gap at the end of a sweeper before the hour, that there is no point in trying to play anything until the following event starts?
 

djsoft

Well-known member
Staff member
It seems that due to Mix point it decided there's a 2-second space between the events so it inserted a sweeper. You should inspect the logs to see what actually happened, it logs events and sweepers and all playback events.
 
The programs either side of the sweeper had no mixpoint. The sweeper selected was 16 sec long; the second program began at about 6 seconds past the hour. While on this point, I note that when I add start, end and mix points and normalise tracks in the music library and look in track tool, they are present. But when I use track tool on the same file in the folder, all processing is absent. Is this a bug? Using latest version. You didn't answer the second part of my question:
What is the effect of reducing the sweeper accuracy to, say, 5 sec? Does RB know if there is a 5 sec gap at the end of a sweeper before the hour, that there is no point in trying to play anything until the following event starts?
 
While on this point, I note that when I add start, end and mix points and normalise tracks in the music library and look in track tool, they are present. But Iwhen I use track tool on the same file in the folder, all processing is absent. Is this a bug?
I found this occurs in 6.0.4.0 but does not in 6.0.4.3!
 

djsoft

Well-known member
Staff member
What is the effect of reducing the sweeper accuracy to, say, 5 sec?
In this case, it can choose sweeper with a duration up to 5 seconds longer than requires. E.g if it needs to "sweep" 30 seconds, it will be choosing any sweeper in duration range [30...35] seconds.

I found this occurs in 6.0.4.0 but does not in 6.0.4.3!
Please try what happens in RadioBOSS 6.0.5 that was just released:
https://www.djsoft.net/community/threads/radioboss-update-announcements.4325/post-35149
 
Top