Disable Start and End Times for Track

phs

Member
We download our news from a third party who produce it for us. We download it every hour, overwriting the old file. The files are never the same length, but RB seems to set a Start and End time for the file once and remember it even if the file becomes longer. The ends result is the news is cut short because RB gets to the "End" time and moves to the next file.

I've tried unchecking both times in the Track Tool dialog, but it keeps coming back.

Is there a way to permanently disable Start/End times for a file?
 

djsoft

Well-known member
Staff member
phs said:
Yes; we're using MySQL DB to speed up the Playlist Generator Pro.
Please try disabling it to see if it fixes the problem. It appears the cache is not being invalidated when the file is changed (RadioBOSS checks the last modified date for files).
 

phs

Member
I added an hourly script on the database server to delete the cache data:

Code:
/bin/mysql \
	--database rb_live \
	--batch \
	-e "DELETE FROM cache2 WHERE fn LIKE 's:\\\\%.mp3';"

This seems to have fixed worked around the issue.
 

djsoft

Well-known member
Staff member
Yes, this will work too. Although I'm not sure why it doesn't work automatically - when the file is changed, its modified date/time will change and RadioBOSS will delete the cache entry. It appears that you have a non-standard configuration, or disabled modified time updates, and this does not work.
 

phs

Member
File timestamps are definitely updating with each new file. See attached.
 

Attachments

  • airnews-file-list.png
    airnews-file-list.png
    12.8 KB · Views: 230
Top