RadioBOSS 6.0 [beta]

Status
Not open for further replies.

djsoft

Well-known member
Staff member
Songs on Demand does not work with version 6.0.0.7
Can you please provide more details on what's not working?

In 6.007 Music Library black frame?
What do you think about to bring back the info window how many entries are deleted when "Remove entries for non-existet track" ? To be shure that is everything ok with the tracks. Now I have no clue what's going on...
Yes, in the next update it will show how many tracks were deleted. As for frame, please try setting different styles from the Library menu.

The problem with commands, which had been solved in version 6.0.0.5 came back in version 6.0.0.7
Can you please specify what kind of problem there is?

Just run the command "weather {city}"
It should also specify the contry like weather New Your, US
 

djsoft

Well-known member
Staff member
The Program restarts when changing the styles by cutting the Streaming transmission
Yes, this is required to change the style. I suggest changing styles when you're off air.

There is manual or tutorial to configure AccuWeather to automate the temperature. In my case openweathermap is not accurate at all.
Just select AccuWeather as weather source in Settings->Scheduler. Please see this user manual page about weather announcements: https://manual.djsoft.net/radioboss/en/automatic_weather_announcement.htm

Drag and Drop complete folder into the playlist is not possible anymore :-(
Thank you, will be fixed.

I have tried variations of the event settings (now using 6.0.0.7) and none of them change the playback. The TTS event plays as soon as the event is triggered. Could there be any other setting(s) that could affect this?
Thank you, we'll check if it's a bug. Another option you can try: turn off the "Overlay playback" option and also turn off "Run scheduled launch without waiting" option - this will make it insert the announcement after the current track to the playlist.

The buffer is 10 seconds. As encoder we use the one integrated in RadioCaster
Does not happen with the same setup here. Is it always happening or sometimes? How do you stop the stream - do you close RadioCaster?
 

djsoft

Well-known member
Staff member
- Time and temperature announcement, is recognized but does not reproduce the temperature file.
Does it show any error messages? Try setting the "Show weather and humidity" option in Settings https://manual.djsoft.net/radioboss/en/view.htm - does it show the weather data in the main window?

- The "Settings" tab when clicked flashes and sometimes closes. The "i" indicator of track quantity and running file time, also blinks strangely.
Note: In a recent test, I realized that this occurs only when the list of "Scheduled Events" is enabled.
This does not seem to happen here. Is it always like this when you use RadioBOSS? Maybe a restart will help.

I lost with this a good time reassembling layout, events, adding playlists, all...
You can create a backup using Settings->Backup and Restore menu.
 

??????? ?????

New member
Good morning from Greece. I have a vision problem and I want to let you know about any problems with the screen reader. With the alt key combination one when the track tools open does not read the buttons. That is, it states a simple button and not exactly what each of them does. Also before I mention the other problems I would like to ask if through the trak tools we can listen to the next song and start it from the point we have chosen. From the View tab, there is no longer an option for columns in the playlist. Going to the settings after the cancel button mentions a button Just like a button and not What exactly does this do. A user who uses a screen reader cannot create more playlists than the one or both already in the program. I am currently looking for a better program and I will inform you about anything else that may arise. Yours sincerely!
 
¿Muestra algún mensaje de error? Intente configurar la opción "Mostrar clima y humedad" en Configuración https://manual.djsoft.net/radioboss/en/view.htm - ¿Muestra los datos del clima en la ventana principal?


Esto no parece suceder aquí. ¿Siempre es así cuando usa RadioBOSS? Quizás un reinicio ayude.


Puede crear una copia de seguridad usando el menú Configuración-> Copia de seguridad y restaurac (

Does it show any error messages? Try setting the "Show weather and humidity" option in Settings https://manual.djsoft.net/radioboss/en/view.htm - does it show the weather data in the main window?


This does not seem to happen here. Is it always like this when you use RadioBOSS? Maybe a restart will help.


You can create a backup using Settings->Backup and Restore menu.
The flickering problem also occurs on my RB. When a certain event is executed the flickering occurs in the list, in the next track marker at the top and in the Disc cover at the bottom. The same thing happens to me in the configuration window. I sent a video email on this topic.
 

Ozeias Almeida

New member
Does it show any error messages? Try setting the "Show weather and humidity" option in Settings https://manual.djsoft.net/radioboss/en/view.htm - does it show the weather data in the main window?
No, no error message is displayed. The temperature file is simply not played. Today I took the time to just perform these tests, even on another PC and I could see that sometimes the file is reproduced as it should. But it is rare to function normally, you can consider 1 chance in 10 attempts.
Yes, the weather data is shown correctly in the main window. It can be seen in the attached image.

This does not seem to happen here. Is it always like this when you use RadioBOSS? Maybe a restart will help.
Also tested on another PC. Yes, it occurs frequently. And I noticed that it happens specifically when "Scheduled events" are recently added to the playlist.
- The "Settings" tab, when clicked, flashes, adds the information and is sometimes completely clean and it also occurs to close itself, making it impossible to click on any option. The "i" indicator for the number of tracks and the playing time of the file below the playlist is also flashing strangely.
Attached image...

You can create a backup using Settings->Backup and Restore menu.
Okay. I already knew about this option but there was never a need to do it. After the incident that I reported, as a precaution I made a backup of the new configuration also by this method. Thanks for the tip! (y)
 

Attachments

  • Erros 6.0.0.7.jpg
    Erros 6.0.0.7.jpg
    369.3 KB · Views: 331
Last edited:
I can think of an interesting option that the scheduled ADVERTISING event has the option of running in an auxiliary list or another tab outside the main list. This would allow that in case of being live the development of the main list is not interrupted. Maybe this is possible today?
 

Ozeias Almeida

New member
I can think of an interesting option that the scheduled ADVERTISING event has the option of running in an auxiliary list or another tab outside the main list. This would allow that in case of being live the development of the main list is not interrupted. Maybe this is possible today?

RB has an option that does something like "Event". Try to use your event by checking the options shown in the attached image. The execution of the files runs in a mini window that opens next to the "Log".
 

Attachments

  • Overlay playback.jpg
    Overlay playback.jpg
    102.5 KB · Views: 171

nelson c

Active member
Does not happen with the same setup here. Is it always happening or sometimes? How do you stop the stream - do you close RadioCaster?
I'm not sure where the problem is. But we broadcast 24 hours with RadioCaster on flac and at times there are cuts in the audio. the stream begins to stutter (and the interface does not show "loading buffer"). Sometimes after several minutes of choppy audio it will advance to the next track.
 

DJboutit

Member
Radioboss for me is still crashing like every 24 to 36 hrs I had to disable to whole program it was in a crash loop play 3 seconds crash restart play 3 seconds crash restart. IMHO version 7 is the least stable version of all the betas of 6

Here is my bug reports
 

Attachments

  • Crash Report.jpg
    Crash Report.jpg
    175.7 KB · Views: 160
  • bugreport_20201021-202911.txt
    66.3 KB · Views: 172
  • bugreport_20201021-202733.txt
    68.8 KB · Views: 155
  • bugreport_20201021-202537.txt
    64.3 KB · Views: 155
  • bugreport_20201021-202424.txt
    67.4 KB · Views: 156

djsoft

Well-known member
Staff member
A user who uses a screen reader cannot create more playlists than the one or both already in the program.
It's possible if you Tab into the playlist tabs and press "+" on the keyboard. We'll address other accessibility issues in the future.

The flickering problem also occurs on my RB. When a certain event is executed the flickering occurs in the list, in the next track marker at the top and in the Disc cover at the bottom. The same thing happens to me in the configuration window. I sent a video email on this topic.
We were never able to reproduce it. Does it still happen with the latest update? How often does it happen?

No, no error message is displayed. The temperature file is simply not played.
Thank you, we'll see what could be wrong with it.

The "Settings" tab, when clicked, flashes, adds the information and is sometimes completely clean and it also occurs to close itself, making it impossible to click on any option. The "i" indicator for the number of tracks and the playing time of the file below the playlist is also flashing strangely.
We can't reproduce it here. You can try using the standard Windows style (select in RadioBOSS "Flat" or "Light" style) to see if it still occurs.

Yes, the other styles working, only the Windows style it not good
Please wait for the next update, we'll make some fixes.

I can think of an interesting option that the scheduled ADVERTISING event has the option of running in an auxiliary list or another tab outside the main list. This would allow that in case of being live the development of the main list is not interrupted. Maybe this is possible today?
You can use the "Overlay playback" option, in this case an event will start within its own window and not modify the main playlist.

I'm not sure where the problem is. But we broadcast 24 hours with RadioCaster on flac and at times there are cuts in the audio. the stream begins to stutter (and the interface does not show "loading buffer"). Sometimes after several minutes of choppy audio it will advance to the next track.
RadioCaster is on the same computer or it's LAN or over Internet? If the connection is not very stable then using format other than FLAC should help, e.g AAC at high bitrate provides adequate quality. It moves on to the next track after the connection is interrupted or buffer is low for some amount of time (when testing here it happens with in several seconds).

Radioboss for me is still crashing like every 24 to 36 hrs I had to disable to whole program it was in a crash loop play 3 seconds crash restart play 3 seconds crash restart. IMHO version 7 is the least stable version of all the betas of 6
Please try running it without any plugins, if it works, then the plugin is the cause.
 

josedisco

New member
Errors in version 6.0.0.7:
- Time and temperature announcement, is recognized but does not reproduce the temperature file.
Note: in the previous version, 6.0.0.6 the same file(playlist) worked normally.

- The "Settings" tab when clicked flashes and sometimes closes. The "i" indicator of track quantity and running file time, also blinks strangely.
Note: In a recent test, I realized that this occurs only when the list of "Scheduled Events" is enabled.

Unusual fact ocorrid: unexpectedly there was a failure in the electrical current for a long period and consequently the PC hung up. Upon returning I had the unfortunate surprise of seeing my entire system misconfigured. Radio Boss had damaged my entire system usage profile. I lost with this a good time reassembling layout, events, adding playlists, all... It would be a good thing to run a test simulating this situation to see if this could turn out to be a recurring problem.
The same thing happens to me, it does not reproduce the temperature if the time command is also in the same playlist. If I put only temperature and humidity it works well at times. The temperature at times reproduces it well and at times does not reproduce it.
 
In my case, updating temperature with Accuweather does not work. Throw this error. The same is not the case Openweather.
 

Attachments

  • Imagen3.png
    Imagen3.png
    425.7 KB · Views: 152

josedisco

New member
Bueno, en español nos entendemos mejor jaja
Me respondieron por ahí que se puede crear un solo evento por horario y dentro de ese evento se puede programar usando la opcion de evento multiple y ahi vas agregando lo que quieras que reprodusca, incluso comandos o rutas... me funcionó de lo mas bien. Chau lista de reproduccion para este tipo de cosa.
En el caso de accuweather me pasa lo mismo, en un pricipio se actualizaba de lo mas bien pero despues de un rato no funcionó mas, creo que eso se debe porque la api es una version trial o demo. Lo cambie a OpenwheatherMap y ahora funciona de lo mas bien.
Saludos!
Jose desde La Plata Bs.As. Argentina

In another post they answered me that this problem is solved by creating an event with multi-event and there programming the time, temperature, humidity directly with the commands. I did it and it worked perfectly. Playlists are not used for these functions.
 
Last edited:

patrick.de-bruyn

Active member
In another post they answered me that this problem is solved by creating an event with multi-event and there programming the time, temperature, humidity directly with the commands. I did it and it worked perfectly. Playlists are not used for these functions.
 

djsoft

Well-known member
Staff member
In my case, updating temperature with Accuweather does not work. Throw this error. The same is not the case Openweather
Please ensure that the city name is correct. The error code is "Unable to get location code" that means it was unable to locate the city in the records.

In another post they answered me that this problem is solved by creating an event with multi-event and there programming the time, temperature, humidity directly with the commands. I did it and it worked perfectly. Playlists are not used for these functions.
It can be in the playlist or in multi-action, should work in both cases, it's a bug in the software.
 
Status
Not open for further replies.
Top