ASIO and Audio Out

Semetery

New member
Hello!

Huge fan of the software, just found it and am trialing and loving it so far, though struggling to get it to work exactly as I need it to unfortunately.

I use an X32 mixer for my live broadcasts. I have it setup so that my mics are all ran via ASIO inputs 1 and 2. I have that setup under Input > MIC as ASIO 1/2. Works great, hit the mic button and my mics come to life.

Now, the problem; I have the main soundcard setup as 3 and 4, which is what I've got routed in my mixer's settings for audio playback. That means I can set any music player up under ASIO outputs 3/4 and they get exclusive sound feed. I was using MusicBee and it works perfectly but when I change the levels or even mute them while using RadioBoss, nothing changes at all, the audio files playing in the playlist's volume don't change or mute unless I use the playlist's volume bar underneath. Nothing I do on the mixer changes the volume even though I have it setup properly. Or well, so I thought.

I'm at a complete loss on what I can do to get this working. Any help would be greatly appreciated. My mixer is ran via USB on my computer, it is used as my main soundcard and I route all audio through it. What can I do to make the playlist audio work with it?
 

Semetery

New member
Any help, please?

I've done a lot of testing and realized that I have the playlist is an OUTPUT, obviously. I had it setup sort of wonky. Anyway, that aside, is there any way that I can route playlist playback to specific channels on my mixer?
 

djsoft

Well-known member
Staff member
I'm sorry for a delayed reply. The topic was missed somehow...

To clarify, you selected ASIO device and channels 3/4 for the "Main soundcard" in RadioBOSS, and it ignores volume controls on the mixer? RadioBOSS shouldn't affect external software/hardware in its ability to control volume.

Semetery said:
is there any way that I can route playlist playback to specific channels on my mixer?
How does mixer appear in the system? If it's available as ASIO device, then you should only select the proper channels.
 

Semetery

New member
No worries, thank you for your reply!

What I came to realize is that those were outputs and not my input channels, I was looking at it completely wrong.

When I set 3/4 (MusicBee, my player) or 1/2 (Mics) either one as a line input and use it in the playlist, my mixer's faders control everything as I want it to. The problem is, I want the playlist of RadioBoss to play via specific mixer channels that I can control, is that possible to do?

Yes, it is ASIO. I don't use the designated system channel because it causes feedback loops when I take callers, I have specific channels for music.

Thanks again, I appreciate your time!
 

djsoft

Well-known member
Staff member
You can set the playback device in the settings: http://manual.djsoft.net/radioboss/en/playback.htm
For the "Main soundcard", click the Select button, select the driver - ASIO, your device and channels where you want it to play. The "Main soundcard" is where playlist is be played.
 

Semetery

New member
I have it set as ASIO and 3/4, which is what I use to play music, and the music comes through the mixer and I can mute it and control it on a monitor level, but the mixer levels don't effect the output in a broadcast or recording within RadioBoss itself. The levels stay the same no matter what I do on the mixer.
 

djsoft

Well-known member
Staff member
Semetery said:
but the mixer levels don't effect the output in a broadcast or recording within RadioBoss itself. The levels stay the same no matter what I do on the mixer.
In this case, one of the possible solutions is to connect mixer output to the computer, select it as one of the inputs in RadioBOSS (Input 1 or Input 2) - http://manual.djsoft.net/radioboss/en/microphone___line-in.htm
Then in settings, on Broadcasting tab use this input as a source for broadcasting - the "Source" selector in the top right corner. You can read more about it here: http://manual.djsoft.net/radioboss/en/broadcasting_internet_radio.htm (scroll to the bottom of the page).
 

Semetery

New member
Thanks!

Almost have it. I have an issue though, my i7 with 8gb's or RAM nearly completely lockup when broadcasting live. Is there anything I can do about that, it's basically unusable.

Disabled Norton and it works great now!
 

djsoft

Well-known member
Staff member
Semetery said:
Disabled Norton and it works great now!
Yes, antiviruses cause problems sometimes... I think we have a recommendation somewhere in the user manual to turn them off.
 
Top