Echo the playback when I turn Mic on

timgreb

Member
Can you tell me why when I click the Mic Button to talk, the music starts to echo and I can't seem to make it make it stop.  It was working great until I moved it and messed up the wiring, not I have it wired right just misconfiged the Radioboss.
Thanks
Tim
 

djsoft

Well-known member
Staff member
Check if you have the "Listen to this device" enabled in the "Sound" control panel applet in Windows. You can also enable the "Output to encoders only" option for MIC in RadioBOSS settings.
 

timgreb

Member
Yes it is set that way, I have every thing disconnectected from the computer but it's still repeating what is playing when I turn the mic on
 

timgreb

Member
Here is Mic setup
 

Attachments

  • radioboss Mic.JPG
    radioboss Mic.JPG
    158.1 KB · Views: 609
  • radioboss Mic.JPG
    radioboss Mic.JPG
    158.1 KB · Views: 421

djsoft

Well-known member
Staff member
The settings seem to be OK.

When MIC button in RadioBOSS is not pressed, do you hear yourself when you talk?
 

timgreb

Member
When I have the mixing board setup yes, but it's like it is repeating the song and making it sound horible... Not sure what to do but it was working great yesterday and now I can't even run a live show.....
It's when the Mic is turned on it gets loud and repeats
 

timgreb

Member
This issue is some thing due to turning on the Mic.  It gets really loud and it don't seem this is much of an issue for you to help me with.. As long as I don't turn on the mic it's fine.
 

djsoft

Well-known member
Staff member
timgreb said:
This issue is some thing due to turning on the Mic.  It gets really loud and it don't seem this is much of an issue for you to help me with.. As long as I don't turn on the mic it's fine.
The MIC gets loud because you have "Mic amplifier" enabled in RadioBOSS - it is set to +10dB according to the screenshots you've posted. I recommend setting it it +0dB, and also move the "Music Level" slider to -15dB.

timgreb said:
Well not impressed with DJSOFT software you want money but your support really sucks and I hope I can get my money back for the upgrade and I will stop using this crap.
The problem is that you incorrectly configured the hardware. There's nothing wrong with RadioBOSS.
 

pety

Active member
timgreb said:
Well not impressed with DJSOFT software you want money but your support really sucks and I hope I can get my money back for the upgrade and I will stop using this crap.
Your knowledge about this piece of software is very, very low. That's why you said stupid things. By the way: The support is the best; you will do not find any like this... If you'll give up guess who's a loser :)
 

timgreb

Member
I have been looking to fix this for 3 days, unless I say some thing stupid no no responds back.. If you think it's my hard ware I haven't changed any thing there, where is a page that shows how to hear what is going to the streamer....If your really able to support, call me at 701-347-2441 and walk me through what the issue is as it runs great as long as I don't turn on the mic
 

timgreb

Member
I guess you would have to hear it on the streamer cause what I hear in the station.. It's looping some where when the mic is cue on, you can tell me all day it's not the software but when I run DRS2006 it don't echo or like a lag in the song when I key up the mic
 

timgreb

Member
I did change the settings and it still does the same thing when I turn on the mic.  It should be pretty easy output from the mixing board into the mic on the computer and when I turn on mic it repeats the music...
 

djsoft

Well-known member
Staff member
I suppose the problem is incorrect mixer wiring. In the result, the sound loops: music goes through MIC input and goes to mixer, then again to MIC and so on, causing feedback loop that sounds horrible.

Try without the mixer. Connect MIC to sound card input and select the input in RadioBOSS. Check how it works. If it works, add mixer to the setup.

To get rid of latency, either upgrade to Windows Vista or newer (7, 10) - it has WASAPI driver that allows low latency. Alternatively, if your card supports ASIO, use this mode; if it doesn't you can try Asio4All: http://www.asio4all.com/

Another important note. If you have hardware mixer board, probably you shouldn't be using the MIC feature at all. This feature exists for cases when there's no mixer.

In case of using a mixer I suggest a setup like this:
1) RadioBOSS playback is routed to one of the mixer's inputs.
2) You also have one or more mics connected to the mixer as well.
3) Mixer output is connected to sound card input
4) Select this input for Input 1 or Input 2 in RadioBOSS (Settings->Inputs); select this input as audio source is Broadcasting tab instead of Audio Mix (the setting is located at the top right corner).

This way, RadioBOSS will broadcast your mixer output. Please let me know if you need more information on it.
 

timgreb

Member
Ok I'll watch the video's an NO I won't upgrade Windows due to you lack of your software, If you had GREAT support my issue would be revolved by now! I have worked on Computers for 36 years and so don't express I don't know what I'm doing, it's the basic setting you should have sent me in the first place but much more easy to say upgrade Windows andtry replaceing parts... This is my last message as I will try to get this configed tomorrow and if not I will go to ... as they have much better support as I have had their products for many years, no need to reply as you have shown me your support.
 

timgreb

Member
Why is it so hard to explain, This happen when nothing is connected to the computer.. Just try me where the files are to compleatly remove this software, I do the rest.
Thanks Tim
 

djsoft

Well-known member
Staff member
I don't know why this is so emotional.

The advice to upgrade Windows was given so that you can get rid of latency. Because newer Windows OS'es have a new feature called WASAPI and that allows low latency times. I don't see a problem in giving such an advice. The lack of WASAPI support in Windows XP is not a problem in our software. As I said before, alternative solution is to use the ASIO4ALL software. This is about solving the latency problem.

About music playing and looping when you press the MIC button. I suppose this is because you have a loop: RadioBOSS plays to mixer, and MIC button routes the sound back to RadioBOSS. So when you press the MIC button, you get audio feedback loop. It goes like this: RadioBOSS->Mixer->MIC->RadioBOSS->Mixer and so on - that's why if you keep the MIC button pressed, you have louder and more distorted sound over (short) time. The core problem here is incorrect wiring, and this is not directly related to our software.

Disconnect everything from the MIC input and try how it works - do you have a loop in this case?
 

timgreb

Member
Yes it does the same thing weather the mixing board is connected or not,  as soon as the mic goes on it does what you stated in your message.
 
Top