RadioBOSS 6.0 [beta]

Status
Not open for further replies.

nelson c

Active member
It's working properly with the same settings here. Does it always happen, or only sometimes? If you place another file after the teaser e.g Music, will it overlap?
It always happens, but if music is inserted after the teaser the mixing point is correct
 

djsoft

Well-known member
Staff member
It's a little bit slower than it used to be with XML files, but not too slow that it causes any concern
Interesting. It should actually be faster. However if your database is on a remote server, this can cause slowdown. makelibrary command improvements are planned for the future versions to make operation faster.

This new version does not allow me to directly drag the files from the windows explorer.
Please ensure that antivirus does not block this operartion.

program crashed today, i had just clicked on a network feed and clicked run now, no error dialog, just program closed and then relaunched, this is the screenshot of the log
Please click Help->Contactg support->Send bug reports, we'll check what could be wrong.

i cannot drag files from windows explorer into the playlist
We can't reproduce it here. Please ensure that antivirus does not block this operartion. You can drag fileas

So, you ignored the suggested Artist report... wonder why :unsure:
Can you please specify what this report should do? Maybe use Report Generator: https://manual.djsoft.net/radioboss/en/report_generator.htm ?
 

djsoft

Well-known member
Staff member
Although it would be a problem of the network, I am cuts are undesirable.
It switches to the next track after it detected that the stream is no longer available and the network buffer was played. It also gives some time for it to refill the buffer, that's what appears to be happening in your case. I don't think this should be changed, as typically network problems are rare and it will have a brief silence and then continue playing.

I do not know if this problem has already been written in another post, but during the execution of a live broadcast link, it is not possible to adjust the transmission time, by operating the mouse with the right button. Nothing happens with this action.
You can't seek a network stream.

The home page still contains version 6.0.1.6.
It's for the beta. The main web site lists the latest version.

If you play a track in the playlist, and it is currently playing in the player, and you delete the track, the next track in the playlist is highlighted. However, it plays the subsequent track, instead of the highlighted one.
Doesn't seem to happen here... Can you please provide more details?

Auto Intro will not work (it is active but nothing happens)
Does it show any error messages in the log? Please re-check your rules to see maybe it's excluding all tracks and therefore AutoIntro is not applied. Try using simple rules with no filters, will they work?
 

djsoft

Well-known member
Staff member
The bug of the blink of the cover, is still present. (When tracks are queued from the scheduler)
Can you please make a video, starting right before it srarts to happen? We were never able to reproduce it here.
It always happens, but if music is inserted after the teaser the mixing point is correct
Do you mean the mix is correct if there's music track, but it's not correct when a short track is the next track?
 

southernfm

Member
Interesting. It should actually be faster. However if your database is on a remote server, this can cause slowdown.
We have a central server running the database for several systems. It is a bit slower to update, but that is to do with our set up. The earlier reports of sluggish performance within the application have been resolved. I don't mind the update process taking a little longer behind the scenes

Doesn't seem to happen here... Can you please provide more details?
Have 3 or more tracks in the playlist. Be in queue mode.

- Play the first track in the playlist
- Delete the track with the delete key while the track is playing. Don't press or click anything else
- The track immediately underneath the one that was just deleted is highlighted
- The highlighted track is skipped, and the track underneath the highlighted track starts playing

I had intermittent results - I think longer tracks sometimes worked better, shorter tracks seemed to always be skipped over. My pre-buffer setting is set to 15000
 

nelson c

Active member
Can you please make a video, starting right before it srarts to happen? We were never able to reproduce it here.

Do you mean the mix is correct if there's music track, but it's not correct when a short track is the next track?
Also send a video with this.
Attach the files that you listen to overlaid (Teaser out and the next track)
 

nelson c

Active member
It switches to the next track after it detected that the stream is no longer available and the network buffer was played. It also gives some time for it to refill the buffer, that's what appears to be happening in your case. I don't think this should be changed, as typically network problems are rare and it will have a brief silence and then continue playing.
At what point did this behavior change?
Perhaps an old version is useful for this task.
 

djsoft

Well-known member
Staff member
At what point did this behavior change?
Perhaps an old version is useful for this task.
It worked differently in the previous version? It shouldn't as there were very few changes regarding network streams playback.
 

ormston

Active member
possible bug.
using the wizard to choose a network stream, then choosing a duration (i chose 3 minutes) then changes the resulting URL to a faulty non playable URL
first screenshot is the wizard and the setting

1608072346990.png


secondly is the comparison of the original and the resulting URL which changes the # on the end from 0 to 180 so therefore now tries to play postcast #180 and therefore fails
http://pd.npr.org/anon.npr-mp3/npr/news/newscast.mp3 #0
http://pd.npr.org/anon.npr-mp3/npr/news/newscast.mp3 #180

the reason for wanting to only play the first 3 minutes in that the news feed kind of pauses after 3 minutes with a station ID then continues for a further 2 minutes, premusably so you can choose to take the shorter 3m news slot or the longer 5 minute one.
I wanted to use the shorter 3 minute version during the drive time show, but cannot due to this limitation/bug
 

nelson c

Active member
It worked differently in the previous version? It shouldn't as there were very few changes regarding network streams playback.
It worked differently in a very old version, if I remember correctly RB 5.2. (He went immediately to the next track)
In 5.9 as in RB 6, it takes about 3 seconds which is not a problem. I am concerned that due to a network failure the radio will stutter. (We have a dedicated service but despite this it happened a couple of times)
 

ormston

Active member
for some reason if i am trying to schedule things to happen next sunday in the scheduler, the run in and run next column feature does not work

1608090900709.png


here all the scheduled events are defined as sunday, but they dont sort correctly by time, as you can see. no matter what i click on on in the columns, they are all enabled. i like to schedule things in advance and it is not working as i would like
 

djsoft

Well-known member
Staff member
using the wizard to choose a network stream, then choosing a duration (i chose 3 minutes) then changes the resulting URL to a faulty non playable URL
first screenshot is the wizard and the setting
This is correct, RadioBOSS uses its own notation to specify the stream duration for the event or playlist item.

In 5.9 as in RB 6, it takes about 3 seconds which is not a problem. I am concerned that due to a network failure the radio will stutter. (We have a dedicated service but despite this it happened a couple of times)
I think certain options can be added to control this. It's always a balance when it decides to abandon the stream or wait a bit and let it play. In most cases, this is preferred, 1-2 seconds of silence and then it continues playing. But if the network is slow, it can pose a problem. In 5.2 things for sure were different as since then stream playback engine was rewtitten at least two times :)

for some reason if i am trying to schedule things to happen next sunday in the scheduler, the run in and run next column feature does not work
It only calculates the Run In field for up to 24 hours.
 

nelson c

Active member
I think certain options can be added to control this. It's always a balance when it decides to abandon the stream or wait a bit and let it play. In most cases, this is preferred, 1-2 seconds of silence and then it continues playing. But if the network is slow, it can pose a problem. In 5.2 things for sure were different as since then stream playback engine was rewtitten at least two times :)

That would be a very good idea :D. I remember in RB 4.9 roughly we discussed this topic (go immediately to next track) and this was a huge improvement. As it worked perfectly for this task we did not update from 5.2 to 5.9 and there this problem started. (Especially with FLAC, which places greater demands on the network). Problems usually occur when the dedicated service shows packet loss at times, it is not frequent but it has happened a couple of times. It is clearly an external issue to RadioBOSS.
 
Status
Not open for further replies.
Top