RadioBOSS 7.0 [beta]

Status
Not open for further replies.
Nowadays it always happens to me. When I select a single folder (without subfolders) it works fine, but when I select a folder with several subfolders it gives me an error, and 90% of the tests I have done, it only selects one song. It should be noted that the fxs and the intro and outro do play.
Looks like there's no bug, it works correctly here. in your log it shows "Bad hook" error. By default, max hook size is 21 seconds, if your hooks are larger than that, it'll result in this error. You can raise the hook limit in Settings, General, Advanced configuration, "Teaser - Maximum hook duration". It's in milliseconds (1 second = 1000 ms).
 
Looks like there's no bug, it works correctly here. in your log it shows "Bad hook" error. By default, max hook size is 21 seconds, if your hooks are larger than that, it'll result in this error. You can raise the hook limit in Settings, General, Advanced configuration, "Teaser - Maximum hook duration". It's in milliseconds (1 second = 1000 ms).
I'm sorry, but I changed this value and it still doesn't work for me. It works fine if I have the auto hook. But he doesn't read the tracks with the hooks set. Some of those tracks that say "Bad hook" don't have the input or output hooks set."
 
I'm sorry, but I changed this value and it still doesn't work for me. It works fine if I have the auto hook. But he doesn't read the tracks with the hooks set. Some of those tracks that say "Bad hook" don't have the input or output hooks set."
Both "Hook In" and "Hook Out" must be set, "Hook In" must be placed before "Hook Out" and duration between them must be in the specified range (max hook duration, as set in the settings); otherwise it will be considered as "bad hook".
 
Both "Hook In" and "Hook Out" must be set, "Hook In" must be placed before "Hook Out" and duration between them must be in the specified range (max hook duration, as set in the settings); otherwise it will be considered as "bad hook".
are set correctly. because inside that folder there is a subfolder with tracks that are currently used and working fine. The question is: why do you look for "hook in and hook out" on tracks that do not have it established?
 
Hi Dmitry,
can you already say when the new version will probably come out? Is it more than a week? I need this information because I want to make updates from windows and RadioBoss at the same time so that my stream is just one night off (backup program). Thx.
 
Hello Dimitri, I would like to please ask to solve a problem. It is normal when an advertisement is out of date to see it in a poorer color than black, a very similar color, more like a light gray color, almost similar to black on our big screen. A more different color like the one I propose would be better, red, more like an expired ad alert. please help to solve this.
 

Attachments

  • Recorte 2.png
    Recorte 2.png
    85.4 KB · Views: 63
Hello,

I notice a difference in visualization in Track Tool.
The waveform is different when moving from a normal view to a magnified view on the same track.

Especially for the max level. The waveform either exceeds the horizontal saturation line or is below it.

The waveform extends beyond this horizontal line either in normal view or enlarged view. It depends on the tracks.

Examples attached: two tracks with the two different views.
  • Track 1: The waveform exceeds the horizontal line in normal view.
  • Track 2: The waveform exceeds the horizontal line in enlarged view (and this track does not distort when playing it. Its sound level is correct).

This difference in visualization does not interfere with the proper functioning of the software.
But I have a little trouble seeing if a track is really saturating or not.

The horizontal line turns red (on my side) when it saturates. This is already a good reference but I would like to see it on the waveform if it is possible.

This viewing problem appears on my two different computers.
 

Attachments

  • Track Tool_Track01_Enlarged waveform.jpg
    Track Tool_Track01_Enlarged waveform.jpg
    152.8 KB · Views: 52
  • Track Tool_Track01_Normal waveform.jpg
    Track Tool_Track01_Normal waveform.jpg
    189.1 KB · Views: 50
  • Track Tool_Track02_Enlarged waveform.jpg
    Track Tool_Track02_Enlarged waveform.jpg
    185.2 KB · Views: 53
  • Track Tool_Track02_Normal waveform.jpg
    Track Tool_Track02_Normal waveform.jpg
    188.7 KB · Views: 49
A more different color like the one I propose would be better, red, more like an expired ad alert. please help to solve this.
Hello,

I am of the opinion not to modify this configuration. That suits me.

However, everyone has their own tastes and colors ;)

I would rather be in favor of customizing the display:
Would you be interested in being able to customize the text color and background color when advertising messages are expired?

This customization would be found in the miscellaneous tab of the settings window, for example.
If yes, question for support: Is this possible in a future update?
 
are set correctly. because inside that folder there is a subfolder with tracks that are currently used and working fine. The question is: why do you look for "hook in and hook out" on tracks that do not have it established?
It checks a number of random tracks from the source. I see where the problem is: if in your source there are many tracks without Hook marks, it will lead to a "too many tracks with no hook points, giving up" error message. This will be tweaked to prevent such situation.

Hi Dmitry,
can you already say when the new version will probably come out? Is it more than a week? I need this information because I want to make updates from windows and RadioBoss at the same time so that my stream is just one night off (backup program). Thx.
There's no precise date set. We're testing it and fixing various minor issues. I think it'll take about a week more. You can use the latest "release candidate" versions, they are good for production.

Hello Dimitri, I would like to please ask to solve a problem. It is normal when an advertisement is out of date to see it in a poorer color than black, a very similar color, more like a light gray color, almost similar to black on our big screen. A more different color like the one I propose would be better, red, more like an expired ad alert. please help to solve this.
Red is already used for "not found" tracks. Grey color we use is a lot different than black, it's much lighter. How it looks exactly depends on the monitor settings - looks the contrast setting is lowered in your case or something else. It think we can add it as configuration so you can change those colors.
 
I notice a difference in visualization in Track Tool.
The waveform is different when moving from a normal view to a magnified view on the same track.
It has to combine audio data in order to draw each "bin". We'll check it again, maybe there should be some improvements. Some other users also reported this issue, so I think we should take a closer look at it.

This customization would be found in the miscellaneous tab of the settings window, for example.
If yes, question for support: Is this possible in a future update?
Yes, it'll be added in one of the future updates.
 
In my scheduler, the manual option disappeared, and I can't activate/deactivate the Scheduler by clicking (On/Off is grayed out). I can activate/deactivate the Scheduler using a command, but not manually. Is this some bug or did I accidentally disable something somewhere?
 

Attachments

  • 2024-02-25_141901.jpg
    2024-02-25_141901.jpg
    138.2 KB · Views: 56
In my scheduler, the manual option disappeared, and I can't activate/deactivate the Scheduler by clicking (On/Off is grayed out). I can activate/deactivate the Scheduler using a command, but not manually. Is this some bug or did I accidentally disable something somewhere?
Looks like you have disabled those options in Settings->Controls.
 
Hello Dmitry, I wanted to remind you again of the hotkey for "Reset Played State". Hadn't seen it in the last updates
Thank you
DJ CEE TEE (Rainer)
Sorry, this was actually added but not committed to the updated version. Will be in the next update :)
 
RadioBOSS 7.0 released!

Download
: https://www.djsoft.net/enu/download.htm

A huge thank you to everyone who participated in our beta testing phase! Your input has been incredibly valuable in shaping the final product and making RadioBOSS better. As a token of our appreciation, we're offering an exclusive discount to beta testers. Simply reach out to us directly if you'd like to take advantage of this offer or if you have any further feedback: support@djsoft.net (or direct message on this forum). Thank you once again for your support and contributions!
 
When I change the style to a dark one in the Music Library, the letters disappear. The letters remain white (instead of changing color) so they are not visible. And when I switch back from the dark style to the default style, an error message appears.
(Latest version of RB, Windows 10)
 

Attachments

  • Library.jpg
    Library.jpg
    111.6 KB · Views: 51
  • error.jpg
    error.jpg
    45.2 KB · Views: 50
In the Ads scheduler, displaying other styles is fine, but when you return from some style to the default style, it also generates an error.
 

Attachments

  • error 2.jpg
    error 2.jpg
    31.4 KB · Views: 46
Status
Not open for further replies.
Back
Top