RadioBoss hogging CPU and keeps crashing helper process it seems (Version 6.0.3)

Pretmaker

New member
So no idea how this happened, it was working without crashing before updating to 6.0.3.

So what happened was a sudden reboot of my system while playing music and checking the volumes. I noticed the PC was hanging or something strange. So it seems to have started with a frozen system while playing music with RadioBoss (testing to see if the new update was stable as I usually do).

So after restarting, errors just keep piling up after starting RadioBoss. In like 1 minute there where like 300 processes called RadioBoss_helper in the taskmanager output. The mouse keeps acting funny as it's loading things in the background. These processes keep hogging random CPU calls and memory, seems to be stuck on something, not outputting any information basically.

Closing RadioBoss will let it output some information in the form of a bugreport. Doubt it's usefull as the bug might be that it can't find RadioBoss open anymore as I closed it after letting it spawn more than 1000 helper processes.
My question is, is this an issue with the release, or is something perhaps screwed in an internal database?
 

Attachments

  • bugreport.txt
    38.1 KB · Views: 179

Pretmaker

New member
As a quick note, I've renamed the file radioboss_helper.exe to something else, and now the issue is gone and RadioBoss seems to work okay-ish? At least my PC didn't freeze in like 3-5 minutes.
 

djsoft

Well-known member
Staff member
According to the bug report, a possible fix: please open Settings, General, click the Advanced Settings button and set "Audio - Read tags in a separate process" to False.
 
Top