Skype calls in RadioBOSS

bobby

New member
Hey Djsoft

I am using the latest radioboss 4.9.1 and i have output to encoders only option turned off

and my voice is still not coming out at all when i have the mic turned when using virtual audio cables

and how can i play youtube videos over the air on radioboss using virtual audio cables
 

djsoft

Well-known member
Staff member
Currently RadioBOSS doesn't support YouTube video playback.

About MIC, first of all try using it with the real sound card - maybe your virtual audio cable software is the problem. Also, do you see any error messages in the bottom right corner? May be RB is unable to use the virtual device for some reason.
 

bobby

New member
Hey djsoft

when i tried it with my normal soundcard it worked 100% fine

so is there any plans to add the youtube video playback and to fix the virtual device problem on radioboss

thanks
 

djsoft

Well-known member
Staff member
Currently there are no plans to support YouTube videos.

For the virtual devices, I don't think it's a problem in RadioBOSS - I think you have problems due to misconfiguration. Try different options eg. DirectSound instead of WASAPI. Also check the virtual device settings and levels.
 
The one day I tested with YouTube videos, I wasn't able to play the video where people could see it, but I could play the audio by going through my sound card and broadcasting it through the mic button on RB.
 

wutzthedeal

New member
So just wanna make sure; with this setup, the host will not hear his own voice?  I don't want to hear my own voice, at all. 
 

djsoft

Well-known member
Staff member
wutzthedeal said:
So just wanna make sure; with this setup, the host will not hear his own voice?  I don't want to hear my own voice, at all. 
Youlll hear yourself in this setup... To avoid this, the setup will be more complicated (more VAC's).
 

wutzthedeal

New member
OHHHHH, I get it.  Ok, I actually have a bat file for that; so what I"ll be doing is running VAC: mic to 1, 1 to 3, 2 to 3, 2 to phones.  So then, I'd have to set up I think 3 for mic in on that third screenshot you showed.  Then, I get only the caller's audio coming in and I presume I'd still hear music/sound effects.  I'll try that and update.

UPDATE: Ok, tried 1, 2, and 3 for input with above setup, with both output to encoders only selection on and off, and anytime I can get my voice to broadcast, I hear it back through my phones.  I have not been able to broadcast my voice at all without mic button pressed, so I have not even tested calls.  In theory, if line 3 is my input, and it has MIC coming to it, and LINE TWO coming to it (if Skype/GV outputs to TWO) then I have my repeaters for LINE TWO to phones, shouldn't I only hear caller and presumably music/sound files?

UPDATE: seem to have it working but with drawbacks.  Changed repeater setup to: mic to 1, 2 to 1, 2 to headset, Google voice to Line 2, then set RB to Line 1 input.  Now, I can make/receive calls and broadcast, but cannot see mic input register on the meter which I rely on to make sure I haven't disconnected or something during shows (it still works with music and such, just not mic input).  So it's all working, no echo, but now no meter.  Ugh, better tho.
 

djsoft

Well-known member
Staff member
wutzthedeal said:
UPDATE: seem to have it working but with drawbacks.  Change repeater setup to: mic to 1, 2 to 1, 2 to headset, Google voice to Line 2, then set RB to Line 1 input.  Now, I can make/receive calls and broadcast, but cannot see mic input register on the meter which I rely on to make sure I haven't disconnected or something during shows (it still works with music and such, just not mic input).  So it's all working, no echo, but now now meter.  Ugh, better tho.
Yes, that's the known issue - the level for MIC is not displayed when "Output to encoders only" option is turned on. This will be addressed in one of the next updates.
 

wutzthedeal

New member
Ok thank you.  One further question; my beta key expires in January; do better testers get a "free" next version?

Also, what I said in my third update above is accurate for anyone using RadioBOSS and Skype (or Google Voice) in order to take/broadcast calls.  Again, here's what you do in condensed form:
Install VAC, set two cables, set up three MME repeaters by opening three instances of it; run Mic to Line 1, Line 2 to Line 1, then Line 2 to headset.  You should NOT be hearing your own voice echo, nor the caller their voice.

In Skype or Google Voice (or similar) Set input to mic and output to line 2.  I would advise unchecking any automatic adjustments within your voip program.

In RadioBOSS, go in and set input to Line 1.  Check the output to encoders only (I did this and I think it's required; will correct if wrong, but it works this way).  Don't tick push to talk if you plan on talking a lot; that would require you to hold the "mic" button down during your broadcast from the main screen.  Also, DON'T FORGET to turn on the mic by tapping that button on the main screen.  Since you won't be able to see your mic input bouncing up and down on a meter until the newer version of RB comes out, just download the free app Pin It, and pin the Mic to Line 1 repeater window open, which will "stay on top" and serve as a voice input meter so you know if there is a sudden problem.  Calls and music sound clean and crisp.  This looks like a really solid program. 
 

djsoft

Well-known member
Staff member
wutzthedeal thanks for the update - I've added your instruction to the first post so others can see it.
Regarding the key, please contact sales@djsoft.net regarding this.
 
P

pety

Guest
Another option to use Skype in RadioBOSS is Voicemeeter - Virtual Mixing Console in connection with VB - Audio Virtual Cable: http://vb-audio.pagesperso-orange.fr/Voicemeeter/index.htm and http://vb-audio.pagesperso-orange.fr/Cable/index.htm .

The Manual for using Skype is here: http://vb-audio.pagesperso-orange.fr/Voicemeeter/Voicemeeter_UserManual.pdf

That is the best solution I discovered.  :)
 

bobby

New member
Hey djsoft

this setup did not work for me at all

Install VAC, set two cables, set up three MME repeaters by opening three instances of it; run Mic to Line 1, Line 2 to Line 1, then Line 2 to headset.  You should NOT be hearing your own voice echo, nor the caller their voice.

In Skype or Google Voice (or similar) Set input to mic and output to line 2.  I would advise unchecking any automatic adjustments within your voip program.

In RadioBOSS, go in and set input to Line 1.  Check the output to encoders only (I did this and I think it's required; will correct if wrong, but it works this way).  Don't tick push to talk if you plan on talking a lot; that would require you to hold the "mic" button down during your broadcast from the main screen.  Also, DON'T FORGET to turn on the mic by tapping that button on the main screen.  Since you won't be able to see your mic input bouncing up and down on a meter until the newer version of RB comes out, just download the free app Pin It, and pin the Mic to Line 1 repeater window open, which will "stay on top" and serve as a voice input meter so you know if there is a sudden problem.  Calls and music sound clean and crisp.  This looks like a really solid program.

so can you help me please

by setting up some screenshots for this setup please

thanks
 

bobby

New member
Hey djsoft

when i ran three 3 mme repeaters, by putting this input in Mic to Line 1, Line 2 to Line 1, then Line 2 to headset

my voice was really quiet and not that loud at all

so what am i doing wrong then
 

djsoft

Well-known member
Staff member
bobby said:
my voice was really quiet and not that loud at all
You should check sound levels everywhere: in repeaters, in virtual and real sound cards. Does your mic sound OK without VAC?
 
Top