Radio Boss Running On VPS

Peter Tate

New member
Hi Guys,

I've got Radio Boss itself working perfectly in a VPS environment. I'm wondering why the Virtual Audio Cables don't show up as an option in the main soundcard settings?

I use Breakaway for audio processing. I know RB supports plugins and others can be used within RB etc. But you really want Breakaway on the job. You install the Virtual cables and everything else sees them except Radio Boss. This is a VPS don't forget and there is technically no soundcard devices in the true sense.

My initial thought was maybe it appears to the registry that there is no soundcards, so no need to load drivers. But why does Breakaway see them and RB doesn't?

I've got a workaround in place using the internal streaming server. But I'd rather use Virtual Cables or Pipes so the audio quality is top notch.

Any suggestions folks?

Cheers All
 

Peter Tate

New member
When connecting using RDP, you need to use the "Play audio on remote computer" option.
I can hear audio on the remote desktop that isn't the problem. Radio Boss doesn't show the Virtual Cables (actually installed and showing in device manager) as an option to select sending audio to them. Yet other software (in the this case Breakaway One) does see them. Can some one take a look at how Radio Boss looks for valid sound devices to send audio to please? This is not an issue if this is in a physical pc. But this is in a VPS.
 

djsoft

Well-known member
Staff member
I can hear audio on the remote desktop that isn't the problem
If you connect to RPD and hear audio on your local PC this is the problem. The audio must remain on the remote machine. If you connect with the "Play audio on a local machine" option, all remote computer devices will be removed.
 

Peter Tate

New member
Thank you Since hearing this bit of advise I've had limited sucess. Some times it works then some times it doesn't. Can a fix be implimented that makes it so RB sees all Sound Devices regardles please.
 

djsoft

Well-known member
Staff member
Can a fix be implimented that makes it so RB sees all Sound Devices regardles please.
It's not a problem with RadioBOSS. If you connect to remote desktop and use the "Play audio on local machine" option, all devices on the remote machine are removed and only one device becomes available (the virtual audio device to send audio over RDP to local computer). Any software will not see any real devices. This is how Windows work. When connecting, you need to use "Play audio on remote computer" option and the problem will be solved.
 

sangatsetia

Member
the problem is not in radioboss, so you don't blame radioboss, try using another software, the same thing will happen, virtual cables will not be perfect for use on VPS. the best solution is to use a VPS that has a physical soundcard, the result is that the virtual soundcard will also be detected and can be used perfectly. it's better to use VST or DSP, it's simpler and there's definitely no problem at all
 

Peter Tate

New member
Thanks Guys,

Yep confirmed. The people I use for the VPS supply their own console for getting remote fingers onto your VPS. Connecting with these method everything is available. It doesn't attempt to bring the sound to you on the local pc.

These guys recommend using the proper app to RDP to your VPS. In my case that's the Windows App from Microsoft. That they tell you to download as part of Win 10. It's this app that I can't seem to find the setting that says "leave audio on remote pc". I know you used to be able to do that in the older versions of RDP (around the XP era).

It's not part of this thread. But I will answer it here. You want Breakaway One doing your audio processing if you are chasing a compeditive sound. It doesn't run as a DSP or VST plugin. Also watch out for the fact that some DSP plugin's (like the Winamp plugin version of Stereo Tool) are only 32bit. Running on the VPS that is 64bit you can use it & the VST version costs money. You then run into problems if your Virtualised Station needs to feed relays (a raw feed) as well as to listeners (a cooked feed) this is all caterred for in Breakaway One.

Cheers
 

Riddle

Member
RB works fine in combination with VST/DSP plugins (e.g StereoTool) and the internal encoder. Not one (virtual) soundcard needed.

You will run into problems eventually on a VPS and opening a console to use audio.
 

Peter Tate

New member
RB works fine in combination with VST/DSP plugins (e.g StereoTool) and the internal encoder. Not one (virtual) soundcard needed.

You will run into problems eventually on a VPS and opening a console to use audio.
I suggest you read my post again.
 
Top