RadioBOSS 6.0 [beta]

Status
Not open for further replies.

patrick.de-bruyn

Active member
normally the music should fade out, then go Offline and stop the playlist.
That doesn't work, there is no fade out
 

Attachments

  • Screenshot_4.jpg
    Screenshot_4.jpg
    283 KB · Views: 208
Last edited:

jpp

Member
Do you have any issues with repeated tracks in the latest (6.0.1.5) update? There were some tweaks made in the past two updates regarding this issue.
i never said i had repeated tracks... i have repeated artists.
Since you doubt me (even with proofs) i stoped testing. Why should i waste my valueable time?
Since you don't implement any of my suggested options 3 years ago, why should i care? Why should i pay for you to satisfy your clients but not me?
I feel discriminated here--- there is this saying in my country "if you don't feel good, leave"... i did, still i'm here but just because you invited me by mail to test this beta and i gave you a 2nd chance, but nothing changed... the repeated artists, your behavior (always doubting my reports) and no new options on track list
 

nelson c

Active member
Hi Dmitry.

We update RB on an air pc that plays streaming 24/7 and is managed through the API .. (Several instances of RadioBOSS that alternate when the one that is on the air begins to load buffer, due to a cut in the transmission)

To "detect" if RB is loading buffer (and then move to another instance) we use the API command playbackinfo. (and we detect the "networkstream" state)

The problem is that in this new version there are times when this does not appear:
-For example when it starts loading buffer: CASTTITLE = "http: //****.sn.mynetname.net: 8040" (the url)
-Other times I've seen CASTTITLE = "[HTTP / 1.0 200 OK] Network Stream"
-In the case that works as usual is when: buffer is being loaded and I manually play on the same track .. in that case if it says: CASTTITLE = "Network Stream"


Is it possible to replicate the above behavior in the playbackinfo command? Thank you
 

nelson c

Active member
There is a bug with the file type for teaser.
The general mix time is used, rather than the one specified for that file type.
 

djsoft

Well-known member
Staff member
downloaded the latest version, scheduder still not opens on view menu and on f3 keyboard button.
This command simply opens the Scheduler tab in the left panel. If the left panel is hidden, it will not be shown.

i also experience issues with "new" intermediate bitrates, on aac format. when i uses 144k, it broadcast in 128k.
to broadcast in 144k, i must set the bitrate to 160k.
Seems to be working correctly here. You can test various settings, if another options works better leave it, e.g. if you need 144kbps and 160kbps provides that, leave it at 160kbps.

That's what I was afraid of. Of course this is not a solution.
As an event there already play a playlist so the scheduled event with "If there are scheduled events in the playlist, enqueue" would go to the end of the playlist and not after advertisements.
For the general playlist contents (e.g. music) events activate the "Insert as regular playlist tracks" option. This is to avoid queued events being inserted to the very end of the playlist. You can read more about the options here: https://manual.djsoft.net/radioboss/en/eventoptions2.htm

My opinion is that advertisements are a priority and should not be possible to split it.
This is possible. Please see my previous reply. Another option is to use multiple action for advert events, to disable the scheduler while the advert is being playing, like this:
scheduler off
...adverts
scheduler on

But the easiest solution is: use "Insert as regular playlist tracks" for music events. Use "If there are scheduled tracks, enque" option for all other events. This will make scheduled events queue after each other and nothing will be split.
 

djsoft

Well-known member
Staff member
normally the music should fade out, then go Offline and stop the playlist.
That doesn't work, there is no fade out
That's because you also have the stop command that stops it immediately. You should remove it as the fadeout command stops the playback anyway.

the repeated artists, your behavior (always doubting my reports) and no new options on track list
A minor fix was implemented recently to handle the case when a track has no tags (in this case it extracts artist/title from the file name). Track List itself was significantly improved in the past years, in terms of its speed and reliability. As for repeated artists, this was not yet possible to fix as we have not able to reproduce it here. I don't say there's no bug, but it seems it requires certain specific conditions to appear - and it also seems that many userts do not face this bug, and we also fail to find it. I'm sorry.

Is it possible to replicate the above behavior in the playbackinfo command? Thank you
I don't think that would be possible as internals were completely rewritten. You can adjust the "Substitune network stream address" option in Settings->View, this is what it shows when it does not have any data regarding the network stream title (or disable this option to see the stream URL).

There is a bug with the file type for teaser.
The general mix time is used, rather than the one specified for that file type.
Are you sure there are no other files type involved with the "Override previous track mix" option?
 

tomimatko

Member
But the easiest solution is: use "Insert as regular playlist tracks" for music events.
Yes that helps.
But we have a lot of scheduled events during the week, so we have to check each of them. And we lose the option "If there are tracks from the schedule in the playlist, enqueue" and "Remove the previous schedule from the playlist" for the next scheduled event... but never mind, it works and that’s important for us.

I think that nobody wants that the ads can be splited ?! So I suggest to add a simple option in ads settings - keep the ads block compact (or something like this).
 
Last edited:

nelson c

Active member
I don't think that would be possible as internals were completely rewritten. You can adjust the "Substitune network stream address" option in Settings->View, this is what it shows when it does not have any data regarding the network stream title (or disable this option to see the stream URL).
This option is enabled, so I think there is a bug there. Sometimes "Casttitle" has the url.

It is possible to add some field in getplayback that announces if it is really playing or if not, for streaming. (For example it is loading buffer or the URL does not work).
I think it would be much simpler, also I suppose that RB really "knows" this.
 

nelson c

Active member
¿Está seguro de que no hay ningún otro tipo de archivo involucrado con la opción "Anular mezcla de pista anterior"?
De hecho sí, pero esto tampoco se respeta.
Este problema empezó a suceder en las últimas betas. Antes funcionó bien.
Aparentemente tengo el crossfader general (3,5 seg)..The next 4-second file is almost completely overlaid.
 

Attachments

  • Sin título.png
    Sin título.png
    72.2 KB · Views: 191

djsoft

Well-known member
Staff member
It is possible to add some field in getplayback that announces if it is really playing or if not, for streaming. (For example it is loading buffer or the URL does not work).
I suppose it can show states like "playing" or "connecting". There's no such state as "failed" as in this case it moves on to the next track in the playlist. Will it suffice?

Aparentemente tengo el crossfader general (3,5 seg)..The next 4-second file is almost completely overlaid.
Can you please start playing the teaser then press Ctrl+F4 and make a screenshot of this window along with the player window?
 
Hello, I see that this new beta version has problems in the library (at least for me) since it throws errors, I attach images of version 6.0.1.6, I hope they correct it or at least return the old library that worked wonderfully. I can also help with the Spanish translation as it has a lot of transcription errors.
Note: this occurs when you are adding folders to the library, which did not happen before.
thanks
 

Attachments

  • Screenshot - 01_12_2020 , 14_19_22.png
    Screenshot - 01_12_2020 , 14_19_22.png
    55.2 KB · Views: 190
  • Screenshot - 04_12_2020 , 9_03_55.png
    Screenshot - 04_12_2020 , 9_03_55.png
    16.5 KB · Views: 192
  • Screenshot - 01_12_2020 , 14_18_54.png
    Screenshot - 01_12_2020 , 14_18_54.png
    56.7 KB · Views: 188

jpp

Member
we have not able to reproduce it here. I don't say there's no bug, but it seems it requires certain specific conditions to appear - and it also seems that many userts do not face this bug, and we also fail to find it. I'm sorry.
the fact that the bug exists is that when same artists plays, there are no reports on the log, and that's why you don't have complaints from other users, you look to the log and don't see errors so you assume everything is working.
Just do a simple test: grab songs from same artist put them to play and check the erros on the log.

About tags, why the file name and not metadata?
to fill the blank fields in metadata?
If you are suggesting i have files with no metadata, you're wrong... There is no music files in my library with empty metadata on fields artists, title or even year. The fields i leave blank is just because i don't use them. I work a lot to have a clean music library because i know how important that is to have a clean automation... so i get a lot of frustration when i get repeated artists.
Does "tags" play a role in "tracklist"? (there are no separation for it on options)
more... when "tags" became more important than artists? So you can't have any song with same tag but it's ok to have repeated artits. Or you can have same tag for 1 or more hours, and still have repeated artists on that hour.
I've already reported this artist bug by the time you implemented tags on RB... before that i've suggested options for tracklist like "less played tracks" and "oldest played tracks" (among some other suggestions that i admit more complicated to be implmented, but not the 2 i mentioned)
3 years passed, and you say tracklist was improved... nothing visible to give users different options of a better automation.

So you may write the word "sorry" but i remind you that you had 3 years since i first mention all of these... Not even 1 was accomplished.
Is there any client here that waited that time? So... sorry is short, i deserve more than sorry.
 

Bensisko

Member
In identifying the file types to define the color and which custom title to send to the server, is it possible to enter the search for more names to search for? This is because many format files you receive are divided into blocks e.g. "block1 block2" it might be useful to use wildcards Es: Lock*
 

Attachments

  • 2020-12-07 18_17_21-Window.jpg
    2020-12-07 18_17_21-Window.jpg
    177.4 KB · Views: 179
  • 2020-12-07 18_16_50-Window.jpg
    2020-12-07 18_16_50-Window.jpg
    192 KB · Views: 172

wagu

New member
There are two problems that I have detected in this version. In configuration when I have saved the information when emitting, then when closing the program the information is empty. I have added the VST plugin and then it has not saved the changes. I don't know if something that I should do differently, but in the previous versions it worked correctly.
I am using window10
 

Attachments

  • emitir.PNG
    emitir.PNG
    6.1 KB · Views: 181
Status
Not open for further replies.
Top