RadioBOSS 5.9 [beta]

RadioBOSS 5.9.0.7 release candidate
  • Minor improvements
  • Bugs fixed
Download: http://dl.djsoft.net/beta/radioboss_beta_5.9.0.7.exe
 
I would suggest that you assign two different keys.
One to open and close the microphone and one just to control the volume of the track.
So we could have more control over the microphone.

Grateful
 
Hi
I do not know if anyone has got the same possible bug, but from version 5.9.0.6 you no longer read the names of The Preset Groups in the Pro Playgenerator, as seen in the attached photo, same problem also in beta version 5.9.0.7.
In addition.. During running Tool Tracks All and not only, in Music Library, the RadioBoss player, slows down a lot, and delay to load from Schedule new events especially programs, to conclude many songs are still without BPM in previous versions and not beta , instead they are written to Tag.
 

Attachments

  • MANCANO NOMI GRUPPO.jpg
    MANCANO NOMI GRUPPO.jpg
    115.7 KB · Views: 278
djsoft said:
RadioBOSS 5.9.0.7 release candidate
  • Minor improvements
  • Bugs fixed
Download: http://dl.djsoft.net/beta/radioboss_beta_5.9.0.7.exe

Will you add now the option "Less played tracks"?  ;D
By the way, "album separation" is not woking
 

Attachments

  • 000config3.JPG
    000config3.JPG
    96.9 KB · Views: 279
Poeta Leandro Souza said:
One to open and close the microphone and one just to control the volume of the track.
The playlist volume is controlled automatically when you turn microhpone on and off - it is configured in Settings->Inputs.

southernfm said:
Both my makelibrary (within RadioBOSS) and API scripts are working again, thank you.
Thanks, good to know!

Marco Nicolosi said:
I do not know if anyone has got the same possible bug, but from version 5.9.0.6 you no longer read the names of The Preset Groups in the Pro Playgenerator, as seen in the attached photo, same problem also in beta version 5.9.0.7.
It appears to be a bug, will be fixed in the next update.

Marco Nicolosi said:
During running Tool Tracks All and not only, in Music Library, the RadioBoss player, slows down a lot
Can you please provide some details?

Marco Nicolosi said:
many songs are still without BPM in previous versions and not beta , instead they are written to Tag.
The BPM was improved in this version, but there are still tracks for which it won't be able to get BPM.

jpp said:
Will you add now the option "Less played tracks"? 
Currently this is delayed due to the way Track List works, there are technical difficulties for such a feature. You can use the playlist generator to select tracks that play fewer than others, use priority rules: https://manual.djsoft.net/radioboss/en/plgen-cat3.htm

jpp said:
By the way, "album separation" is not woking
Please note that album is only checked for the same artist, same album name by different artists are considered as different ablums.

nelson c said:
Hi Dmitry, Is possible by API writetag to write the intro of a song?
Currently not - will be added soon, it's not a big deal :)
 
djsoft said:
Poeta Leandro Souza said:
One to open and close the microphone and one just to control the volume of the track.
The playlist volume is controlled automatically when you turn microhpone on and off - it is configured in Settings->Inputs.

southernfm said:
Both my makelibrary (within RadioBOSS) and API scripts are working again, thank you.
Thanks, good to know!

Marco Nicolosi said:
I do not know if anyone has got the same possible bug, but from version 5.9.0.6 you no longer read the names of The Preset Groups in the Pro Playgenerator, as seen in the attached photo, same problem also in beta version 5.9.0.7.
It appears to be a bug, will be fixed in the next update.

Marco Nicolosi said:
During running Tool Tracks All and not only, in Music Library, the RadioBoss player, slows down a lot
Can you please provide some details?

I explain better, during the work of the Tools Tracks All the Hard Disk, works a lot, and it seems that this operation takes a lot of resources, in fact, this slows down a lot the creation of a Playlist requested by a preset in the schedule event. I also tried to create a playlist from a single preset from my pc I5 slows down by many minutes the load of the playlist in the live player.
When Tracks All is not active everything works regularly.


Marco Nicolosi said:
many songs are still without BPM in previous versions and not beta , instead they are written to Tag.
The BPM was improved in this version, but there are still tracks for which it won't be able to get BPM.

jpp said:
Will you add now the option "Less played tracks"? 
Currently this is delayed due to the way Track List works, there are technical difficulties for such a feature. You can use the playlist generator to select tracks that play fewer than others, use priority rules: https://manual.djsoft.net/radioboss/en/plgen-cat3.htm

jpp said:
By the way, "album separation" is not woking
Please note that album is only checked for the same artist, same album name by different artists are considered as different ablums.

nelson c said:
Hi Dmitry, Is possible by API writetag to write the intro of a song?
Currently not - will be added soon, it's not a big deal :)
 
nelson c said:
djsoft said:
Quote from: nelson c on Today at 01:34:13 PM
The simultaneous player does not work when relay is activated. Is this intentional?
It is usually useful for reproducing local advertising, over remote transmission.
Yes, all RadioBOSS air is muted when the relay is active. We'll add an option for events to allow them being played over the relay.
It's good news

By the way, what is the reason why DTMF cannot be checked from the main output? Is it something technical?
I think it's the most common and useful.
Even with this relay function
I think it happened to answer this  :)
 
djsoft said:
Quote from: jpp on November 16, 2019, 08:46:44 AM

    Will you add now the option "Less played tracks"? 

Currently this is delayed due to the way Track List works, there are technical difficulties for such a feature. You can use the playlist generator to select tracks that play fewer than others, use priority rules: https://manual.djsoft.net/radioboss/en/plgen-cat3.htm

Last time i used the playlist generator i didn't like the result of it, but maybe because i don't know exactly how to use it because the logic is not very clear to me.
So, maybe you can help me get the result i want for my playlists, wich is: Get ALWAYS the less played songs in each music folders.
Fo example, if i add a new song (zero counts) i want it to start being selected and play more until it gets the same playcount of the others.
Hope you can help' me.
Thanks in advance
 
The readtag command has a problem reporting multiple tags (separates them with space). Then when the WriteTags command is called, the assigned tags are lost. (A single tag is created with all the concatenated strings)

<TagInfo>
<File FN="C:\Users\Nelson Casey\Desktop\borrar.mp3" Duration="26972" Artist="" Title="probando" Album="" Year="2018" Genre="" Comment="" BPM="" Rating="0" Playcount="0" LastPlayed="" UserField1="" UserField2="" UserField3="" UserField4="" UserField5="" TypeIdentifier="" TagsList="Categoria: Recurrente MiListaDeTemas"/>
</TagInfo>
 

Attachments

  • 0.png
    0.png
    2.5 KB · Views: 272
  • 1.png
    1.png
    9.9 KB · Views: 271
Marco Nicolosi said:
I explain better, during the work of the Tools Tracks All the Hard Disk, works a lot, and it seems that this operation takes a lot of resources, in fact, this slows down a lot the creation of a Playlist requested by a preset in the schedule event. I also tried to create a playlist from a single preset from my pc I5 slows down by many minutes the load of the playlist in the live player.
When Tracks All is not active everything works regularly.
Track Tool only loads track on startup (to display tags and wavbeform) and then does nothing.
When you create a playlist, it will read tags for all tracks in all categories that are used in the playlist.
Anyway, this is not changed compared to previous version. If you use antivirus, it can be the cause for slowness.

nelson c said:
By the way, what is the reason why DTMF cannot be checked from the main output? Is it something technical?
I think it's the most common and useful.
Even with this relay function
Not technical, but how do you want to use it? To deactivate the relay by DTMF signal? In this case you can use the same source for DTMF as you use for Relay.

jpp said:
Fo example, if i add a new song (zero counts) i want it to start being selected and play more until it gets the same playcount of the others.
You should use Priorities in playlist geenrator: https://manual.djsoft.net/radioboss/en/plgen-cat3.htm
Multiple rules can be specified, e.g. one for tracks with Playcount less than average, and another for tracks with Playcount = 0 to increase priority even more.

nelson c said:
For some reason some tags are not painted in the tag editor
It is possible if you changed the color recently and the change was not pick up by the track information tab. Is tit the case?
 
nelson c said:
The readtag command has a problem reporting multiple tags (separates them with space). Then when the WriteTags command is called, the assigned tags are lost. (A single tag is created with all the concatenated strings)
The tags are separated with Tab character, in XML it is presented as . I did a quick test and readtag command properly returns tags separated by tab. You need to use the same separator when you call the writetag method, e.g.
Code:
... TagsList="Categoria: RecurrenteMiListaDeTemas" ...
 
djsoft said:
Quote from: nelson c on November 17, 2019, 03:27:55 PM
By the way, what is the reason why DTMF cannot be checked from the main output? Is it something technical?
I think it's the most common and useful.
Even with this relay function
Not technical, but how do you want to use it? To deactivate the relay by DTMF signal? In this case you can use the same source for DTMF as you use for Relay.
I never found the meaning to have to play 2 streaming instances to play exactly the same.
I even read in a forum that after several days there may be a difference of minutes between the same stream. Which is a problem
If streaming is analyzed from the main output, it makes everything simpler, for example it allows you to change the streaming source with the scheduler
Even Zararadio works this way
 
djsoft said:
Quote from: nelson c on November 17, 2019, 11:39:12 PM
For some reason some tags are not painted in the tag editor
It is possible if you changed the color recently and the change was not pick up by the track information tab. Is tit the case?
That's right, they are labels created since the last opening of RB. When restarting the program they are painted correctly
 
I think your example forgot about the tag. Here is how it appears here with two tags
Code:
TagsList="Cat: Alta Cat: Recurrente"

A quick test using Chrome: I get the xml with readtag, without modifying it I write the command writetag and execute it, then tags will be broken.

Also with the following Delphi code the same thing happens. (At no time modify the tags)
Code:
 if ReadTag(ObtenerRuta(ListadoCanciones, ListadoCanciones.Selected.Index), ANode) then
      Begin
          ANode.ChildNodes.FindNode('File').SetAttributeNS('Artist', '', EditEdicionInterprete.Text);
          ANode.ChildNodes.FindNode('File').SetAttributeNS('Title', '', EditTitulo.Text);
          ANode.ChildNodes.FindNode('File').SetAttributeNS('Year', '', A?oCancion.Text);
          ANode.ChildNodes.FindNode('File').SetAttributeNS('Album', '', EditAlbum.Text);
          ANode.ChildNodes.FindNode('File').SetAttributeNS('Genre', '', EditGenero.Text);
          ANode.ChildNodes.FindNode('File').SetAttributeNS('Comment', '', EditComentario.Text);
RBAPI.Get(URLParaLlamarAAPI('&action=writetag&fn=' + EncodeURIComponent(ListadoCanciones)) + '&data=' + EncodeURIComponent(ANode.XML));
    End;
 
nelson c said:
I never found the meaning to have to play 2 streaming instances to play exactly the same.
This is a technical issue as DTMF and other parts are separated and therefore each one uses the same stream. This will be improved in the future, and only one stream will be used.

nelson c said:
That's right, they are labels created since the last opening of RB. When restarting the program they are painted correctly
Thanks, added to the list of bugs.

nelson c said:
A quick test using Chrome: I get the xml with readtag, without modifying it I write the command writetag and execute it, then tags will be broken.
I think Chrome displays tabs as spaces. You probably need to use the "View source" option to view the XML data as-is.

As for the Delphi code, I'm not sure what happens there as code is not complete, it looks likle that one of the functions you call modify the XML data, removing the "#&9;" character and changing it to something else (space).
 
Back
Top