Trial version distortion limitation?

VictorM

New member
Hi there! I'm trying out RadioBoss and I'm hearing a lot of distortion/aliasing as if I'm playing back audio at 64kbps quality. Is this a limitation of the trial somehow? I can't find anything about this. I'm trying to build a stream that captures video and audio from system playback, so this needs to sound as sharp as possible. Thanks!
 

djsoft

Well-known member
Staff member
Trial does not have such sort of a limitation, if you capture playback from some other device, it can be the issue. What happens if you play the files directly in RadioBOSS?
 

VictorM

New member
I get this compression artefacts when playbacking directly in RadioBoss, without broadcasting or recording the output.
Meanwhile I was struck by the limition of not being able to add video files to Media Library, so it seems I need to look further for our playback system. Thanks for the help!
 

djsoft

Well-known member
Staff member
I get this compression artefacts when playbacking directly in RadioBoss, without broadcasting or recording the output.
The problem could be with the files themselves, e.g. they are corrupted. RadioBOSS uses the standard decoding libraries, and this is the first time we've ever heard of any such playback problems.

Meanwhile I was struck by the limition of not being able to add video files to Media Library
To add video files, please enable it in Tools->Settings.
 

VictorM

New member
Hi Dmitry! After trialing for a while, added a sound card (fixed the distortion issues), bought RadioBoss advanced but after re-installing everything on a fresh Windows laptop, I have a bizzare mix of problems:
32bit version - can play mp4 or mov files, but while using playlist generation + filtering with a tag, the videos are being filtered out of the final generated playlist.
64bit version - can't play mov files, but the playlist generation works as expected.
Any ideas what I'm doing wrong? Cheers!
 

djsoft

Well-known member
Staff member
Can you please send us one of such files? You can use a file sharing service if the file is large.
 

djsoft

Well-known member
Staff member
This file plays fine here in both x86 and x64 versions. Please ensure that you have installed video playback plugin - it needs to be installed for every version. This file doesn't play without the plugin.
 

DJ L33

New member
Hi there! I'm trying out RadioBoss and I'm hearing a lot of distortion/aliasing as if I'm playing back audio at 64kbps quality. Is this a limitation of the trial somehow? I can't find anything about this. I'm trying to build a stream that captures video and audio from system playback, so this needs to sound as sharp as possible. Thanks!
How did you get a free trial? I purchased the software, but I can't get a reply to my emails and i cant figure out how to get a trial from the webpage
 

djsoft

Well-known member
Staff member
After you download and install it, it starts in Trial mode. There's nothing else that needed to be done.
 

VictorM

New member
Hi Dmitry! Sorry to bother you again. I'm actually still expriencing distortions while playing back certain video files. I uploaded here a short export from the original, aired file and what I recorded with OBS: https://we.tl/t-PZ9smWgVOg
Any idea why this happens? I've set the broadcast to be sent via virtual audio driver, monitoring on a Behringer UCA202, both set to 48khz.
 
Last edited:

VictorM

New member
Just 2 add on the things I tried: I set the whole playback, monitoring drivers to 44.1khz as well, with no improvement.
 

djsoft

Well-known member
Staff member
I don't think we can do anything about it. The video file you've sent to us before plays fine here. If it doesn't play properly, it can be due to your specific configuration. In any case, we can't really fix the video playback because it uses external library (VLC) to handle video playback.
 

VictorM

New member
I don't think we can do anything about it. The video file you've sent to us before plays fine here. If it doesn't play properly, it can be due to your specific configuration. In any case, we can't really fix the video playback because it uses external library (VLC) to handle video playback.
Thanks, Dmitry. I've tracked down the problem to libVLC and trying to sort it out on the dev forum/discord channel
 
Top